RIPE Database: Mail Updates Not Working

Incident Report for RIPE NCC

Resolved

Mail Updates were failing due to an issue with the central mail server. This has since been resolved at 12:14 UTC
Posted Jul 20, 2026 - 14:14 CEST

Investigating

We're investigating issue with auto-dbm@ mails are not delivered to WHOIS servers since 20260720 09:06 UTC. Outgoing notification emails and other update methods are not affected.
Posted Jul 20, 2026 - 11:06 CEST
This incident affected: RIPE Database.