We have received confirmed reports of email delivery issues affecting messages sent to the RIPE NCC. Some senders may have received temporary delivery failure notifications, but affected messages are expected to be retried and delivered automatically.
Posted Jun 05, 2026 - 20:02 CEST
Investigating
The certificate authority we use changed the intermediate certificate of the certificates we use on our email MX servers, which we missed. This led to the TLSA records for our email MX servers to be incorrect. The TLSA records have been updated today around 16:00 Amsterdam time, but people verifying these may experience issues for the TTL duration of the records, which is 86400 seconds after the update in the worst case scenario.
Posted Jun 05, 2026 - 16:18 CEST
This incident affects: Email to/from the RIPE NCC.