Planned Maintenance: Meeting Software

Scheduled for Aug 20, 15:30 - 17:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 14, 2026 - 17:09 CEST

Scheduled

The meeting registration software will be unavailable between 15:30 - 17:00 (UTC+2) on Thursday, 20 August 2026. During this time, registering for RIPE NCC organised events and registering to attend and vote at the October 2026 General Meeting will be unavailable.
Posted Aug 14, 2026 - 17:00 CEST
This scheduled maintenance affects: Non-Critical Services (Meeting Software, Meeting Registration Software).