Issue accessing RIPE NCC Services

Incident Report for RIPE NCC

Resolved

We experienced issues with accessing the LIR Portal, SSO and other services were login was required. Access has now been restored.
Posted May 20, 2026 - 15:01 CEST

Investigating

We are experiencing issues with a number of our services. We are investigating and will update this announcement once we know more.
Posted May 20, 2026 - 13:42 CEST
This incident affected: Non-Critical Services (Billing & Payments, RIPEstat, RIPE Atlas, RIPE Labs, Meeting Software), RPKI (RPKI Dashboard), and LIR (Member) Portal, RIPE NCC Access.