In addition, this root cause led to a near-full outage for RIPEstat between 0:38 and 1:29. We apologize for this inconvenience and are working on the monitoring gaps that are present for partial failures.
Posted Jul 03, 2025 - 11:56 CEST
Investigating
We intermittently have periods with an increased error rate affecting RIPEstat. This occurs for a fraction of requests when it happens.
Users may encounter errors when accessing RIPEstat on the web or making API calls. Data may fail to load in widgets, and API responses may return an HTTP error.
The underlying cause is intermittent issues with one of our (internal) backend APIs. This backend system degrades in performance, but not enough to raise alerts. In turn, this degrades the performance of RIPEstat. We currently have limited metrics for the performance of this system. This means there is user impact before the issue is visible in our current monitoring solution.
We are actively implementing enhanced monitoring to improve visibility into error rates for both the main RIPEstat application and the specific backend system. This will help us better identify and resolve issues in the future.
You may need to reload the page if you encounter an error, or retry failed API calls. We will update this notification as soon as we have more information.
Posted Jul 03, 2025 - 08:23 CEST
This incident affects: Non-Critical Services (RIPEstat).