Connectivity Issue with AFAS

Incident Report for RIPE NCC

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 12:10 CEST

Investigating

We are currently facing connectivity issues with AFAS, which are affecting the invoice functionality in the portal. Members may experience difficulties viewing or paying their invoices.
Posted Apr 03, 2026 - 12:08 CEST
This incident affected: LIR (Member) Portal.